Cascading Style Sheets

I ntroduction

HTML allows designers to determine how a document is viewed in a browser over the
World Wide Web (WWW) by applying tags that manipulate the appearance or assign
stylesto thetext. The purpose of cascading style sheets (CSS) isto allow Web authors to
manipulate a Web page's appearance without affecting its HTML structure (Rotter, Kahn,
& Anderson; 2000). For example, if al sub-headings in a document need to be displayed
inalarger font and italicized, then the appropriate HTML tags must be placed around
each sub-heading in the text of the code. CSS allow designers to make these
specifications without applying individual line code in the HTML document. Thus, CSS
separate presentation and content on the Web (Nielsen, 1997).

To facilitate the formatting of Web pages, the World Wide Web Consortium (W3C)
developed guidelines for CSS. W3C has developed guidelines for two kinds of CSS,
Level 1and Level 2. Level 1, allow authors to define about fifty propertiesincluding
fonts, color and background, text spacing, alignment, margins, box properties, and
classification properties. Level 2, extends these property definitions by 70. The
additional definitions beyond screen-based presentation and include media-specific
presentations, such as visual browsers, aural devices, printers, Braille devices, and
handheld devices. Level 2, aso supports content positioning, downloadable fonts, table
layout, features for internationalization, automatic counters and numbering, and some
properties related to user interface (Nielson, 1997).

Significance of CSS

If properly applied, CSS can give adesigner the ability to separate content and
presentation. However, not all Web designers are convinced that CSS are reliable tools
or that content and format should be separated at all in Web publishing. Advocates of
CSS claim that CSS allow for cleaner HTML, which is easier in development stages and
facilitates in the creation of templates (Y oung, 1997). Additionally, page-wide or site-
wide changes are much easier to implement when using CSS (Rotter, Kahn, & Anderson;
2000).

Supporters of CSS also recognize limitations, one of which is Web browser support.
Versions 3.0 of Operaand Microsoft Internet Explorer and Version 4.0 of Netscape
Navigator support propertiesfor Level 1, and 4.0 and later versions of all three browsers
support properties for Level 2. Some Web devel opment tools have solved the problem of



browser support by translating style sheet propertiesinto HTML code, but Dreamweaver
isone of the only programs that will automatically convert stylesto HTML tags. In
addition to the limitations of browser support, other concerns about designers using CSS
to override an individual’ s browser settings have been raised. When designers misuse
style sheets, pages become inaccessible. (Pozadzides & Quinn, 1997)

Some Web authors oppose the use of CSS. For example, Korpela claims that CSS are not
sophisticated enough to solve the serious problems involved in separating format and
content on the Web. The complexity of CSS invites misunderstandings and misuses. In
addition to flaws in the basic setup and structure, Korpela argues that the fundamental
principal behind the development of CSSis archaic because CSStriesto fit publishing on
the Web into the traditional publishing model, where format and content are separate
issues. In Web publishing, where there are many technological implications of
formatting, it isimperative for formatters to understand the constraints of the Web and to
understand mark up languages. Therefore, he believes that we should not try to separate
the two functions.

Korpela s argument against creating tools to facilitate Web development with an archaic
mind set and an “in the box” approach isvalid. CSS are not perfect. CSS can, however,
help designersto set certain styles more accurately and mre conveniently, and this point
has caused many Web designers to think highly of CSS.

Discussion

CSS can be created by using anormal text editor, which is similar to creating HTML
code, or by using software tools. This paper will discuss how to use Dreamweaver, a
software tool, to create CSS.

The Basics of CSS Tags, Selectors, and Declarations

In order for your style sheet to properly display your Web page, you must attach the Web
document to a style sheet. Attaching the style sheet can be done by adding thisHTML
tag into the Web page’ s source code: <STYLE TYPE="text/css’>. Close thetag with
</STYLE>. Stylesshould be set right before the <BODY > tag. Between the <STYLE>
tags, assign attributes by using the rules established by W3C.

Each rule has a selector and a declaration. The selector isthe part of the code that links
the HTML to the style you want to appear. The declaration isthe part that defines the
attributes that will appear in the displayed Web page.



Example 1
If you want all of your H1 headings to appear in a 24-point font size and in the color blue,
use the following tags:

<STYLE TYP="text/css’>
H1 {font size: 24pt; color: blue}
</STYLE>

<BODY>

In this example, astyleis attached to a specific HTML tag. “H1” isthe selector and
“{font size: 24pt; color: blue}” is the declaration.

Internal Syle Sheets Using Dreamweaver-Adding Stylesto HTML Tags

Dreamweaver assists you in adding in selectors and declarations. Example 1 above will
be used to show you how to use the CSS Styles palette in Dreamweaver to assign certain
propertiesto a specific HTML tag. To open the CSS palette, go to Window > CSS
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Use the arrow to select “New...” from the pop-up window (see diagram above).



The “New Style”’ dialog box will display on your screen. For “TYPE,” select the
“Redefine HTML Tag” radio button. For “Tag,” use the pop-up menu to select the
HTML tag, hl. Click “OK.” (See diagram below.)
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The next dialog box that will appear is the “ Style definition for h1” box. Since we want
every element that has an hl tag to appear in a 24-point font size and in the color blue, we
use the category “Type.” (Click on the other categories including background, block,
box, border, list, positioning, and extensions to detemine all of the properties that can be
manipulated with CSS in Dreamweaver.) Fill in 24 for “Size” and choose a shade of blue
for “Color.” Click “OK.” (See diagram below.)
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View the HTML code in Dreamweaver by selecting WINDOW > HTML SOURCE.
Note that the code generated is the same asin Example 1 above:
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Note the HTML syle notation encloses the style element content (i.e. '—and __ >). This
isaway to avoid displaying the style sheet code in old browsers that do not support CSS.

Internal Syle Sheets Using Dreamweaver—adding custom styles

In Example 1 above, you learned how to attach a style to a certain HTML tag. Inthe
event you want to define a certain style that you can apply anywhere in your HTML
document without attaching it to an HTML tag, you may want to create your own selector
that linksthe HTML to the style. CSS callsthisa“custom class.” A class can be linked

to any HTML tag on a page.



To open the CSS palette, go to Window > CSS palette.
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Use the arrow to select “New...” from the pop-up window. (See diagram above.)

The“New Style” dialog box will display on your screen. For “TYPE,” select the “Make
Custom Style (class)” radio button. For this example, we will define atag called
“answers.” We want al of the answers on the Web page to appear in italic typeface and
inthe color red. For “Tag,” typeinthe name of your class with aperiod in front of of it.
(See diagram below.)
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The next dialog box that will appear isthe “ Style definition for .answers’ box. Since we
want every tag associated with the class to appear in italic typeface and in the color red,
we will use the category “Type.” Use the drop-down menu to select “italic” for “Style”
and choose a shade of red for “Color.” Click “OK.” (See diagram below.)
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Now view the HTML code in Dreamweaver by selecting WINDOW > HTML SOURCE.

(See diagram below.)
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Note that the selector is“.answers.”




External Syle Sheets Using Dreamweaver

If you have more than one page to which you want to apply the same styles, you can
create an external style sheet and link to several Web pages. To open the CSS palette, go
to Window > CSS palette. Select the “Open Style Sheet” icon. (See diagram below.)
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The “Edit Style Sheet” dialog box will display on your screen. (See diagram below.)
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Usethe “New...” button to add the style definitions. Each time you add a style, select
“New...” and the “New Style” dialog box will display on your screen. Add al styles
using this“New...” feature. Note that asyou create new styles, the list appearsin the
“Edit Syle Sheet” screen. When all styles are entered, export the CSS by selecting File >
Export > Expor CSS Styles... The “Export Styles As CSS File” dialog box will display
on your screen. (See diagram below.) Name the file with the .css extension (for

example, mystyles.css), and then click “save.” mystyles.cssis an external CSS on your
hard drive.
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Linking External Syle Sheetsto an HTML File Using Dreamweaver

In Dreamweaver, open the HTML document to which you want to link the external style
sheet you previously created.



To open the CSS palette, go to Window > CSS palette. Select the “ Open Style Sheet”
icon. (Seediagram below.)
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The “Edit Style Sheet” dialog box will display on your screen. Click on “Link...” (See
diagram below.)
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The“Link External Style Sheet” dialog box will display on your screen. Click on
the"Link” radiobutton to the right of “Add As” and then click on “Choose...” (See
diagram below.)
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After you click “Choose...,” you will find the .css document that you saved earlier. Click
“OK.” This will bring you back to the “Link External Style Sheet” dialog box, but the

file name you chose will appear in the “File/URL” text box. (See diagram below.) After
you click “OK,” you will be back to the “Edit Style Sheet” diaglog box. Notice that the

name of your file appears in the text box. (See diagram below.)
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Converting CSSinto HTML Using Dreanmweaver

Dreamweaver is one of the only software tools that can change CSSinto HTML to help
with browser compatibility. When converting CSSin an HTML document,
Dreamweaver will create a new document with HTML, leaving the CSS document in its
original form. In order to convert the document, select File > Convert > 3.0 Browser
Compatible...When the “Convert to 3.0 Browser Compatible” dialog box appears, select
the “CSS Stylesto HTML Markup” and click “OK.” (Seediagram below.) Y our new
document, written in HTML, will appear on your screen.
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Summary

CSS were created by W3C to help designers separate content from presentation.
Although many designers are advocates for CSS because they are much more convient
than tedious HTML code, opponents argue that the separation of content and format isa
traditional idea that needs to be abandoned. Opponents also claim that CSS are too
complex, often leading to errors, but designers have overcome the complexities of CSS
by using software tools that often eliminate common errors. One popular software
package, Dreamweaver, helps designers avoid mistakesin HTML, helps them overcome
browser support problems, and hel ps them create both internal and external style sheets.
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